Katmir Media Caching ทำงานร่วมกับ Mikrotik RouterOS ในการ Bypass ในกรณีระบบ Maintenance – (มีคลิป)

ข้อมูลพื้นฐานที่ใช้ในตัวอย่างการตั้งค่าในเอกสารนี้

  • VCB Katmir Media Caching IP address = 192.168.254.20
  • การตั้งค่าตัวแปรตามตัวอย่างนี้มีผลในส่วนของ Case Sensitive

เริ่มการ Config VCB Katmir ทำงานร่วมกับ Mikrotik กัน

  1. ก่อนอื่นให้เราไปที่ Console ของ VCB Katmir ดังนี้ http://192.168.254.20:81 แล้วใส่ Username/Password ตามที่ได้ตั้งค่าไว้
  2. ไปที่เมนู Setting -> Advanced -> Misc แล้วไปกด Enabled ที่หัวข้อ Mikrotik Checker เพื่อทำการเปิด Port Checker ซึ่งเราใช้ Port UDP 2048 ซึ่งเป็น Port มาตรฐานในการตรวจสอบ Service Cache Engine
    image-6
  3. ต่อมาเริ่มต้นที่การตั้งค่าที่ RouterOS ในส่วนของ Mangle สำหรับการตรวจค่า Status ของ Katmir VCB ว่า Cache Service Engine ทำงานอยู่หรือไม่ โดยการใส่สร้าง Address list เพื่อเป็นตัวแปรส่งค่า Alive ตามข้อที่ 4
  4. /ip firewall mangle
    add action=add-dst-to-address-list address-list=VCBKATMIR_alive \
    address-list-timeout=10s chain=prerouting comment="VCBKATMIR Alive Packet" \
    dst-port=2048 protocol=udp src-address=192.168.254.20

    รายละเอียดดังนี้
    – address-list: คือชื่อที่ตั้งมาเพื่อดู status alive เช่นเราตั้งว่า “VCBKATMIR_alive”
    – address-list-timeout: เวลาที่ Mikrotik จะทำเงื่อนไข เปิดหรือปิด Route ซึ่งมีรายละเอียดใน Script ต่อไป
    – src-address: เป็น IP address ของ VCB Katmir ของคุณเอง

    image-2                  image-3

  5. กำหนดค่า Comment ใน Route ซึ่งหากคุณมีการกำหนดอยู่แล้วให้ ทำการบันทึกค่านี้ไว้เพราะเราจำเป็นต้องตั้งค่าให้ตรงกันใน Script Scheduler ซึ่งตามตัวอย่างเราตั้ง Comment ว่า “VCBKATMIR-Route”
    add check-gateway=ping comment=VCBKATMIR-Route distance=1 gateway=\
    192.168.254.20 routing-mark=VCB_Katmir_IBM
  6. สุดท้ายใส่ค่าใน Scheduler เพื่อควบคุมการเปิดปิด Route ใน Mikrotik ในกรณี Detect VCB Katmir Cache Service Engine ปิดการใช้งานหรือว่าอยู่ในช่วง Maintenance ระบบ
  7. /system scheduler
    add interval=10s name="Monitoring VCBKATMIR Route" on-event=":global VCBKATMIR\
     \r\
     \n:if ([/ip firewall address-list find list=VCBKATMIR_alive] = \"\") do={\
     \r\
     \n:if ($VCBKATMIR != \"down\") do={\r\
     \n/ip route disable [find comment=\"VCBKATMIR-Route\"]\r\
     \n:set VCBKATMIR \"down\"\r\
     \n:log info \"VCBKATMIR is DOWN now!, It has disabled Route to Cache\"\r\
     \n# Remove all connections\r\
     \n /ip firewall connection tracking set enabled=no\r\
     \n :delay 5s\r\
     \n /ip firewall connection tracking set enabled=yes\r\
     \n}\r\
     \n} else={\r\
     \n:if ($VCBKATMIR != \"itsup\") do={\r\
     \n/ip route enable [find comment=\"VCBKATMIR-Route\"]\r\
     \n:set VCBKATMIR \"itsup\"\r\
     \n:log info \"VCBKATMIR is UP now!, it has enabled Route to Cache\"\r\
     \n\r\
     \n# Remove all connections\r\
     \n /ip firewall connection tracking set enabled=no\r\
     \n :delay 5s\r\
     \n /ip firewall connection tracking set enabled=yes\r\
     \n}\r\
     \n}\r\
     \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive \
     start-date=oct/13/2016 start-time=00:00:01
  8. เมื่อเราใส่ค่าครบทั้งหมดแล้ว เราสามารถทดสอบง่ายๆ โดยการดึงสาย LAN ที่ต่ออยู่กับเครื่อง Server VCB Katmir เราจะได้ผลลัพท์ดังนี้
    8.1 ค่า VCBKATMIR_alive ใน Address-list จะเป็น 0
    8.2 เราจะเห็น Log โชว์ว่า Ethernet Port down และ VCBKATMIR is Down now!, it has disabled Route to Cache
    8.3 Port Route จะโชว์ unreachable และจากนั้น Route จะถูก Disable ทันที
    8.4 Connection ทั้งหมดจะถูก Clear พร้อมๆ กันนั้น Route จะย้ายไปยัง WAN ซึ่งในส่วนนี้ user ที่ใช้งาน Web Browser จะไม่มีผลกระทบใดๆเลย (ถึงแม้ในความเป็นจริง Wan ได้ถูกสลับไปแล้ว)

ทั้งหมดนี้จะช่วยให้การบริหารจัดการ Cache ง่ายขึ้นในช่วงของการทำ Maintenance ไม่เช่นนั้น บางครั้งเราจะเจออาการเล่นอินเตอร์เนตไม่ได้เพราะ Cache Engine Service ไม่ทำงานทั้งๆ ที่เรา Ping ตัว VCB Katmir ได้ และนี้เป็นการแก้ปัญหาจุดอ่อนในส่วนของการทำ Route PBR Transparent Proxy กับ Mikrotik RouterOS โดยเฉพาะ ซึ่งหากเทียบการทำ Transparent Proxy ด้วย Protocal WCCP บนอุปกรณ์ Cisco แล้ว เราจะไม่เจอปัญหาพวกนี้เลย

** ต้องการดูเต็มหน้าจอกรุณาเลือกกด Pop-out จะมุมขวาบนของ Video Clip